14.1-Job Title attribute data is not visible on catalog user contact page

Document ID : KB000108865
Last Modified Date : 31/07/2018
Show Technical Document Details
Issue:
Please see the screenshots of the problem :

The problem is caused by the special character '/' . catalog product has a bug with displaying  a contact's job title with '/' in it .

1. in service desk GUI , go to Administration -> Service Desk -> Application Data -> Codes -> Positions , create a job title with has / in it , for example : "100528 / Business II analyst "

2. in service desk GUI , edit a contact's profile , select this job title "100528 / Business II analyst" for this contact and save it . It can display fine on service desk's contact profile
User-added image.

3. Now , in Service Catalog GUI , go to Administration -> Users -> locate this user , open this user's profile , you will see the job title of this contact display empty .

User-added image
Environment:
Service Catalog 14.1 , 17.1 
Cause:
The problem is caused by the special character '/' . catalog product has a bug with handling display a contact's job title with '/' in it .
Resolution:
This bug is addressed on   14.1.05.1 ( 14.1 CP5 rollup1 patch ) for catalog 14.1 version   and on  17.1 Rollup2 patch for catalog 17.1 version