10.3 SS Thread Exhaustion causing SS performance issues

Document ID : KB000125088
Last Modified Date : 22/01/2019
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Issue:
After installing 10.3 the SS was stopped b/c it was acting flaky.  Users noticed the OneClick client was slower to populate and alarms were not generating right away.  When the SS was restarted it crashed.
Cause:
The SpectroSERVER was using more threads than needed to process data causing excessive overhead on the SpectroSERVER process.
Resolution:
This is resolved in Spectrum release 10.3.1.  If you are running Spectrum 10.3 and cannot upgrade to 10.3.1, then please open a ticket with CA Support (http://support.ca.com) and request 10.3.0 patch Spectrum_10.03.00.PTF_10.3.013.  This patch must be installed on top of the second bi monthly patch Spectrum_10.3.0_BMP_10.3.002.  The release notes show the following:

Symptom : SS crash will crash while activating FI model. 
     Resolution: SS crash does not crash while activating FI model.
 
The fix for this is a change to the internal SpectroSERVER thread processing.
Additional Information:
The second bi monthly patch (Spectrum_10.3.0_BMP_10.3.002) is available here:

ftp://ftp.ca.com/pub/CA-SPECTRUM/Updates/GA/Spectrum_10.03.00.BMP_10.3.002/